Let's prepare your mac for development. Stop having version conflicts.

Installing Ruby[rvm] Python[pyenv] NodeJS[nvm]

Hi everyone,

During my first few years of programming, the first struggle I have is how to manage multiple versions of Ruby.

It's been a very painful programming experience. I have to keep upgrading Ruby in the older projects in order to maintain them.

I know it's a good practice to keep everything up to date, but sometimes, it's just a side project and not worth spending time on.

That was 9 years ago.... If you are having the same problem as me with Ruby, Python, and NodeJS.

Here is the solution,

  • Ruby use RVM
  • Python use pyenv
  • NodeJS use NVM

I made a video to explain.

Alt Text

Hope you find it useful